Back to overview
Resolved

Planned System Maintenance

Jul 3, 2026 at 7:00pm UTC  –  Jul 5, 2026 at 7:59pm UTC
Affected services
Web Application
United States (Non-Enterprise)
Primary (Non-Enterprise)
Primary (Non-Enterprise)
Webhook Delivery (Non-Enterprise)

Resolved
Jul 5, 2026 at 7:59pm UTC

Maintenance ended

Created
Jul 3, 2026 at 7:00pm UTC

The platform will be under maintenance during the extended 4th of July long weekend.